Getting Started Browser Support

Recurly Application

To ensure the best possible experience, the Recurly application is designed for modern desktop browsers that automatically update. Browsers without reliable automatic update systems are supported as current version -1.

  • Chrome: latest version
  • Firefox: latest version
  • Edge: latest version
  • Safari (OS X): 8+
  • Internet Explorer: 11+
 

Recurly Hosted Solutions

Recurly’s hosted solutions include the Hosted Payment Pages and Hosted Account Management tools. These pages meet the following browser requirements:

  • Chrome: latest version
  • Firefox: latest version
  • Edge: latest version
  • Safari (OS X): 8+
  • iOS: 6+
  • Internet Explorer: 9+